How to disable hardware acceleration in atom version 1.0.0 in linux


#1

HI everybody, i’m having an issue with my atom since i installed it a few months ago. When i minimize atom and then i click on it on the taskbar to maximize it again, the menu bar disappears and sometimes parts of the editor also disappear.

This happened in chrome and chromium too, but i just disabled the hardware acceleration in those and now they work fine, but i can’t find that option in atom.

Somebody knows how can i disable hardware acceleration in atom?


#2

I don’t believe there is currently a way to disable the hardware acceleration in Atom. I could be wrong about that though, I haven’t followed the feature.


#3

So, if it is not possible to disable that, do you know a solution for my problem. I like atom very much, but it’s annoying when parts of the window disappear.


#4

Same problem and same solution for chromium here with Linux Mint Xfce. A workaround for Atom would be great. (Atom Version is 1.2.4)


#5

The latest version of Atom is v1.4.1. You might want to try updating to the latest version to see if that makes anything better. (I don’t know that it will, but it’s generally better to be on the newest stable version.)


#6

Thank you for your fast reply, but after I wrote my last reply I just realized that my version (v1.2.4) isn’t up to date, so I updated atom to v1.4.1 now. Sadly the problem still occurs.


#7

I was afraid of that … sorry :frowning:


#8

Hi all,

for those who are still wanting to disable the hardware graphics here what you could do. Note, that for my example, I’m using virtual box running ubutun but at the very lest I’ve given you an idea of what you can do for your system.

In sumarry

when you run Atom, give it the –disable-gpu option to disable the hardware graphics support. This can be done directly when executing atom via the terminal or automatically if using ubuntu .descktop files to execute atom.

How to

via the Terminal
when ever you call atom via terminal jsut make sure that you add –disable-gpu

atom –disable-gpu &


Via Ubuntu GUI `.desktop’ file
to get ubuntu to open atom with hardware graphics disabled then you need to edit the atom.desktop file like so;

  1. sudo nano /usr/share/applications/atom.desktop

  2. Then change line
    Exec=/opt/atom/atom %F
    to
    Exec=/opt/atom/atom --disable-gpu %F


-Ron


Input boxes blackout when Atom window is maximised