How to disable autocompletion for "patfh"?


#1

I’m probably missing something obvious, but every time I type path into my Ruby code, autocomplete changes it to patfh and if I’m not careful, it fills in what I don’t want. I always have to stop and make sure it’s not changing path.

I can’t figure out where autocomplete-ruby is picking up the patfh from, or how I can take that one out of the autocomplete suggestions. Any ideas?

Thanks in advance!

Oh, I’m on macOS Sierra, Atom 1.12.7 (it’s been a long-standing problem, but I’ve not had to type path as much as I am in this project, so it wasn’t as irritating as it is now!)


#2

Are you sure it’s not a snippet that’s causing it?


#3

Thanks for asking! I did check that, but as I’m not overly fond of snippets (I forget what I’ve defined), I don’t tend to use them. I checked the “snippets” menu, again, just to be sure, but no snippets in there.

Is there another place I should be looking for those? I poked around the .atom directory, but couldn’t see anything. I even did a search on Google and the GitHub repositories for autocorrect-ruby and rsense.

I really do get the feeling I’m missing something obvious!

Thanks, again!


#4

Snippets usually reside in snippets.cson. If there’s nothing there, then please tell me exactly which packages you have installed and exactly which key sequence leads to path being changed to patfh.

autocomplete-ruby seems to rely on RSense, so if it’s really that package doing the interference, then it may be that program that has a typo in it.


#5

Apologies… A few unexpected days off!

The packages:
aligner-ruby@1.5.0
asciidoc-preview@2.7.1
atom-alignment@0.12.1
atom-ctags@5.0.0
autocomplete-go@1.3.0
autocomplete-ruby@0.2.3
builder-go@1.0.1
clipboard-history@0.6.6
coverage@0.6.1
cucumber@0.5.0
cucumber-step@0.2.0
environment@1.3.1
git-plus@5.29.1
git-time-machine@1.5.4
go-config@1.2.4
go-debug@0.1.22
go-get@2.1.1
go-plus@4.3.2
godoc@1.1.1
gofmt@1.2.0
gometalinter-linter@1.2.2
gorename@1.1.0
hard-wrap@1.1.0
hyperclick@0.0.39
language-asciidoc@1.6.2
language-dotfiles@1.0.0
line-count@0.5.0
linter@1.11.18
linter-golint@0.3.0
linter-js-yaml@1.2.6
linter-ruby@1.2.4
minimap@4.25.7
navigator-go@1.1.3
package-list@0.1.2
project-manager@3.3.3
project-view@0.6.1
ror-refactor@0.3.1
ruby-block@0.3.5
ruby-test@0.9.17
ruby-test-switcher@1.2.3
tester-go@2.0.2
todo-show@1.8.0
unity-ui@2.1.7
yard@0.3.1

I type ‘pat’ and it comes up with ‘patfh’ as the first option in the list:

I tried running a grep for “patfh”, but the output was nonsensical.

Thanks for your continued help!


#6

Okay, so it’s a meaningful function name and not a typo. Since autocomplete-ruby draws on RSense, I don’t see an easy way to modify what you’re seeing. However, if you’re just typing path, that’s going to be four key presses regardless, either p-a-t-tab or p-a-t-h.


#7

Yeah, after a bit of investigation, I’ve come to the conclusion that it’s all but impossible to fix without getting into rsense. And while I tried to figure out some time for that, my time isn’t my own, these days!

Thanks for your help! :slight_smile:


#8

No problem. :slight_smile: