How to disable arrow keys in autocomplete-plus


#1

I’d like to disable the arrow keys from moving through the autocomplete-plus list of completions and use ctrl-n/p instead so I added the following to my keymap.cson:

'atom-text-editor.autocomplete-active':
  'up': 'unset!'
  'down': 'unset!'
  'ctrl-p': 'core:move-up'
  'ctrl-n': 'core:move-down'

But even after relaunching the arrow keys still move through the completions list. Is there another way to disable them or a bug in autocomplete-plus?


#2

This is a known issue that is being tracked here:

Please subscribe there for updates.