How to change font?


#1

How can I change the font in atom? Every time I try changing the family font it changes to another default font instead of the one I’m trying to change to. Any ideas?


#2

I’m not sure what problem you have but let me suggest you try out the fonts package. It has a ton of fonts included. I don’t know if it will help your problem.


#3

actually the font i want to use is for another language…i have it installed on my system but i cant seem to get it working in atom


#4

It would help if you included what platform you’re running on: OS X, Windows, Linux? The answer to this question is sometimes different depending on which you are using.


#5

Sorry im on windows 10


#6

Here’s some alternate approaches if you can’t get the font family field to work:


#7

I tried what you suggested and it works as far as making the font italic however the font itself does not change


#8

anybody else have any suggestions?


#9

@raelyard, do you have any suggestions?

@phsyco009, what is the name of the font?


#10

the name of the font is Jameel Noori Nastaleeq. Its an urdu language font. However I can’t change to any font its not just this one.


#11

I am able to change my font on 1.2.4 on Windows 10 without any issue both via the Settings window and via editing config.cson. I don’t see an Atom version listed here. Is it different?


#12

Can you try the specific font @phsyco009 mentioned? Jameel Noori Nastaleeq


#13

Yeah, tried that - worked fine.


#14

could you please share your settings and maybe some screenshots? i wonder if it might be an issue with my theme? im using the theme called one dark


#15

screenshot of my settings with the desired font installed and rendered:


#16

Actually, that appears to be the default Windows font of Times New Roman rather than the desired font. Can you:

  1. Put the cursor on one of the lines with text
  2. Open the Dev Tools
  3. Go to the Elements tab
  4. Find the <div class="line cursor-line"> element and highlight it
  5. Switch the right hand pane in the Dev Tools to “Computed”
  6. Scroll to the bottom to see “Rendered Fonts”


#17

I see differences with using Times New Roman vs Jameel Noori Nastaleeq. My dev tools doesn’t seem to show a Rendered Fonts - maybe I’m doing something wrong. The font-family showing up in the Filter is showing whatever I have in the config.cson.


#18

ok i seemed to have fixed the problem…i think i may have incorrectly typed the name…lol…who woulda thought… thanks for all the help