How do you turn off folding?


I don’t use folding and I accidentally bump fold icons and they take up space in the gutter. Can I turn folding off?

What is this between gutter and text editor

I don’t think there is a way to completely disable it. It is part of Atom Core. You might be able to use some CSS trick to make the clickable area not display and thereby be non-clickable and not take up visible space though?


Yup as @leedohm said a css rule like this one should do the trick:

.foldable .icon-right {
  display: none;


It worked, but only after adding !important. I thought user settings would always apply last but I think a lot of wrong things.


It should, but if the original rule is more specific then you’ll have to match the specificity or use !important. I must admit I did not verify what rules was applied on the folding icons, maybe there’s a .gutter that gets in the way.


I just looked up how specificity works for the first time. I was surprised that it was simply the count of the number of classes (when there are only classes). That’s pretty crude.

Anyway, the one that won was .editor .gutter .line-number .icon-right which has more classes than your .foldable .icon-right.


Nothing is ever easy. This started happening …

Just to make things even more fun, at random times they all jump back-and-forth between this position and the correct left position about once per second.


Maybe in that case using a pointer-events: none and a visibility: none would make more sense.


Added a feature request for this too:


So you mean to leave the space there. That would be an improvement.

In any case this is not a big enough problem for me to spend time on it, I’ll play with it when I’m bored.


I got bored and found something that seems to work nicely. The jumping left and right was because of the foldable class selector. That class is only on lines you can click on to toggle. This matches the fold icon div on every row.

.icon-right {
  width: 0 !important;


This is an old post – has this feature (disable folding icons in gutter) ever been added?

I have the same issues as @mark_hahn. I don’t fold my code and I often clic it by mistake.



Hi, mi first post here :smiley:

We have some way that actualy works for disable folding ?

I tried some tricks from this post but it dosent work , could be that i don’t do it well , i’m quite new.

So if someone could help me with an explanation for a newbie will be great :stuck_out_tongue:



workaround :

atom-text-editor::shadow .gutter .line-number .icon-right {
    display: none;


Unfortunately, that hides bookmark icons as well.

I modified it a little bit to show bookmarks:

atom-text-editor::shadow .gutter .line-number:not(.bookmarked) .icon-right {
    height: 0;
    overflow: hidden;

But now, if there’s a bookmark on a foldable line, clicking the bookmark icon (normally does nothing) folds the code. So, if you don’t use bookmarks, Sigz’ method is better (and saves space in the gutter).

I changed the background color of the gutter for bookmarked lines, so the fold icons can be properly hidden:

atom-text-editor::shadow .gutter .line-number {
    &.bookmarked {
        background-color: fade(@background-color-info, 20%);
    .icon-right {
        display: none;