How do you get Atom to support processing in Windows?


#1

I want to use processing but I don’t want to use its default text editor, I’d rather use Atom, how do I get Atom to support Processing?


#2

Google tells me this


#3

That’s what i did, it doesn’t work :frowning:


#4

That’s not much (read: nothing) to work with. You’ll need to provide details if you want help. For starters, did you follow the installation guide in the README.md file?


#5

Ok so I finally managed to get it working but I still am getting some errors with Linter-Java-Processing package

[Linter] Error running Processing
See Console for more info. (Open View -> Developer -> Toggle Developer Tools)

Do you know how can I get to this?

Also I am not getting any highlights if there are errors, how come?


#6
  • My bad, don’t use the processing package in Atom. It’s not maintained, and the GitHub repo has been made read-only. The author says to use script instead, which seems like it will work the same.

Do you mean the linter-processing-java package?

To get to dev tools, do what the instructions say: in the View tab (up there with File, Edit, etc.), go to Developer -> Toggle Developer Tools. The error should be there, and you can paste it in this forum if the following doesn’t solve your issue.

The instructions on the linter-processing-java page say to open Atom via the command prompt (so open the command prompt and run the command atom .). Test this, and see if it fixes your problems.

Because the highlighting is done by linting, which is the thing currently not working.


#7

Yes I mean linter-processing-java

SO I instaleld Script and disabled processing, I am still getting the same error when I save. I have opened developer options but I don’t know what element do I copy and paste.

Do I have to run Atom via the command prompt?


#8

Try it, and see if the error still happens. I know it’s not optimal, but the README.md file indicates it’s necessary. If it works, at least we know what the issue is. If not, we’ll need to look further.


#9

Sorry but what is the command I need to run using cmd?


#10

In Wiindows, you should open the command prompt and run the command atom . (this will open Atom with the current directory as the project folder; you could provide a path instead of . if you like)


#11

How do I run and execute my code then as I replaced processing with scripts package?


#12

First things first, we are trying to solve the error you say you’re getting. Did opening Atom from the command prompt help?


#13

Yes I did man and well it opened my project. Now when I press Control S I am getting the same error.


#14

In that case, you’d better post the error to this thread. The full error should be in the dev tools, like it says.


#15

image

This is the error I keep getting, who should I post this to exactly? Is it the linter team?


#16

WHen I tried to execute the code (I managed to figure out how to run it) this is what I get ‘Somedirectories…\Question1’ does not exist.

It does exist. what is going on?


#17

That looks like part of an HTML page as seen from the dev tools. The error messages are under the Console tab, as stated by the documentation that you quoted, and have red backgrounds.

‘Somedirectories…\Question1’ does not exist.

Is that literally the exact text that Atom is giving you? If not, then you will have to be more forthright with us and share the actual error message. Feel free to obscure your username, but please don’t hold back anything else. If we can’t see what you are seeing, we can’t be helpful.


#18

This is the error message I get when I start Atom up via cmd and when I save the file within Atom
image

This is what I typed out in cmd

This is the error message I get when I execute the program using the scripts package by pressing ctrl + shift + b

This is the error under the console tab (using developer tools)
image

I am able to run the code just fine within Processing studio, but how come Atom can’t run it?


#19

Have you tried it with the linter disabled? Linting and code execution are very different processes, and will be done by different packages.

You’ll notice that the error you’re getting when trying to run the script is 'C:\Temp\Testing' does not exist.


#20

I’m guessing that the error message is correct. C:\Temp\Testing does not exist. There’s a C:\Temp\Testing\, but you probably don’t have an extensionless file with the same name in the same folder. The question is why script appears to be telling processing to look for C:\Temp\Testing instead of C:\Temp\Testing\Testing.pde.

This is the error under the console tab (using developer tools)

And what do you see when you expand the error message by clicking on the arrow next to AssertionError?

I am able to run the code just fine within Processing studio, but how come Atom can’t run it?

It hasn’t been established that Atom can’t run it. You have tried two packages, script and linter-java-processing, which seem to have different errors. I can tell you with complete certainty that Atom can do what you want. Someone just has to tell it how. If the existing packages don’t contain the correct instructions for interacting with an external program, that doesn’t reflect on Atom’s capabilities. At this point, since script is giving you a bad response, I think you should go for process-palette instead and learn enough about the Processing CLI to write an instruction to send the current file to the processing command.