How do I turn off soft wrap?


#1

hello
how do i fix this?

i want this text on one line


How to I gets lines to wrap to the width of the window?
#2

It is on one line. But if you want it to not wrap, you can:

  1. Open Settings View using Cmd+, on macOS or Ctrl+, on other platforms
  2. Click the Editor tab on the left
  3. Uncheck “Soft Wrap”


#3

not working.


#4

That setting only affects new editors. You can use my soft-wrap-indicator package to easily toggle the setting for the currently open editor.


#5

I forgot to mention
"Soft Wrap" is uncheck by default.


#6

worked perfectly until the yesterday update.


#7

Soft wrap is forcibly turned on for files with long lines, to avoid hangs when attempting to load or edit the file.


#8

ok. how do i stop this?


#9

I don’t think you can, short of building Atom yourself. The value is hardcoded.


#10

noooooo
noo
now i have to find another editor
:sob:


#11

I second the “now I have to use another browser”. :tired_face:

MAX_SCREEN_LINE_LENGTH = 500

Not the end of the world, just inconvenient and unexpected.


#12

30 mins ago everything was on one line. I clicked soft wrap to take a look at something and now it will only toggle between hard and soft wrap. For me, atom has been working on no wrap for over a year. Im using atom with Nuclide.

config.cson:

  core:
    allowPendingPaneItems: false
    customFileTypes:
      "source.ini": [
        ".buckconfig"
        ".flowconfig"
        ".hgrc"
      ]
      "source.json": [
        ".arcconfig"
        "BUCK.autodeps"
      ]
      "source.python": [
        "BUCK"
      ]
    disabledPackages: [
      "spell-check"
      "node-debugger"
      "set-syntax"
      "linter"
      "tree-view"
    ]
    telemetryConsent: "no"
    themes: [
      "atom-dark-ui"
      "atom-dark-syntax"
    ]
  editor:
    fontSize: 11
    invisibles: {}
    scrollPastEnd: true
  "exception-reporting":
    userId: ""
  linter:
    errorPanelHeight: 142
  "linter-bootlint": {}
  "linter-jshint": {}
  "linter-ui-default": {}
  minimap:
    absoluteMode: true
  "node-debugger":
    nodePath: "/usr/local/bin/node"
  nuclide:
    "nuclide-buck": {}
    "nuclide-diagnostics-store": {}
    "nuclide-diagnostics-ui": {}
    "nuclide-home": {}
    "nuclide-ocaml": {}
  "one-dark-ui": {}
  pomodoro:
    period: 60
  "remote-edit":
    showHiddenFiles: true
  "remote-sync": {}
  tabs: {}
  "todo-show": {}
  "tree-view":
    hideVcsIgnoredFiles: true
  welcome:
    showOnStartup: false

#13

This really should be a setting since hard coded value is not a good idea and is annoying to new users since the setting appears to not work.


#14

For others who have followed the above without success, in my case I wanted to specifically disable the default soft wrap for markdown documents. I believe the settings for those languages were overriding the “core” -> “editor” -> “softWrap” settings. So I explicitly overrode those and the defaults now work. You can see how to do this by looking at: Soft wrap support, but only for Markdown?


#15

I should clarify that the reason why the advice above wasn’t working for me is because it suggested overriding the “core.editor” settings, which I did, but in my case but the problem was that a more specific language setting was overriding my override. So the solution was to do an override to the override.


#16