How do I make newline auto indent to spaces, not tabs?


#1

Here’s a GIF that illustrates the issue.


#2

If you open the command palate and use the Editor: Toggle Soft Tabs command (you can just type tabs to get to it quickly), it’ll toggle the tab style for the active file only between spaces and hard tabs.

If you want to change the default setting so it always uses spaces instead of tabs, open up the settings view and check “Soft Tabs” under the Editor Settings.