How do I enable Shadow DOM?


#1

I wanted to change my background image and in doing so I some how disabled Shadow Dom. When I enable Editor-Background it tells me that I have to enable it somehow.

I looked everywhere in the settings and could not find a check box for it. I admit that I am new to this Text-Editor but I am a little confused. HELP?!


#2

There are multiple packages available that let you choose your own background image. If one doesn’t fit your needs, you can probably learn from those package how to setup your own image.


#3

Thanks. I am using a different package but had to toy with the thing to get it working. I have so much to learn “sigh”


#4

What’s the exact message?


#5

The Shadow DOM setting has been removed since July 8 and a further PR will remove all logic.


#6

The exact message for the editor-background package is:
"Use Shadow DOM option must be enabled to run editor-background"
Was working until very recently (I just noticed it this morning).

Quick fix for editor-background:
In [path to atom]\packages\editor-background\lib\editor-background.coffee

Find line 29: shadowDomEnabled = atom.config.get 'editor.useShadowDOM'

Add the following right below it:
shadowDomEnabled = true

Forces the check to true without mucking about in the conditionals that use the flag below.


#7

Update is live for editor-background that fixes this problem (so you all can ignore my quick hack).