How do I dismiss an autocomplete suggestion in Atom?


#1

When I’m writing Docstrings in Python3, I’m ending all of my sentences with periods and I see an autocomplete suggestion like this:

In this case it wants to replace the string “wager.” with “wagerself.”

If I press Enter or Tab the string replaces. I’ve messed around with all the logical buttons (Including adding an extra space which doesn’t work), and nothing will allow me on my merry way to a newline.

This problem occurs both with and without the autocomplete-python package installed.

I do want to use auto-complete when I type a dot after an object, just not in the comments.

Is there a way to either:

  1. Dismiss the autocomplete suggestion as they come up.

– or –

  1. Change the autocomplete to be aware of the context, i.e. not autocomplete dots when I’m in a string/comment.

#2

Press Esc


#3

The more robust solution is to go to the autocomplete-plus settings (Settings -> Packages -> autocomplete-plus) and change the autocomplete trigger to tab or tab always, enter when suggestion explicitly selected.


#4

Perfect, thank you.


#5

I’m having the same problem, though I already knew about Esc.

I’d just like to point out that this is a new problem. I’ve been writing python docstrings in atom for more than a year and I believe this problem (suggesting self. when you type . in a comment) only showed up sometime in the last month.