How do I disable autocomplete

#1

I loath autocomplete. Not for any specific reason, it just bugs me a lot.
I’ve got it turned off

disabledPackages: [
“autocomplete”
“archive-view”
“language-ruby”
“language-ruby-on-rails”
“welcome”
]
But it still engages. “do+enter” gets converted to what ever local variable I have that starts with “do” and “end + enter” suffers the same… Now I can remember to press a space after or the escape button, but that feels ugly…
I would love some advice on how to actually turn the autocomplete off.

4 Likes
#2

What version of Atom are you using? autocomplete is no longer bundled with Atom; autocomplete-plus is now instead. Assuming you have a version of Atom with autocomplete-plus bundled, you can effectively disable it by unchecking “Show Suggestions on Keystroke” – this is a bit better than disabling the package outright because you can always manually activate autocomplete with a keyboard shortcut if you ever change your mind while coding.

6 Likes
#3

cool… I’ve not used auto complete for over 7 years now… I doubt I’ll ever turn it on :slight_smile: Thank you so much… it makes perfect sense, I thought it was a version bump.

#5

Sorry to bump this topic
…especially just to say that
but I’m new to Atom and every minute is such a joy this one is too much I can’t hold it
this baby here in autocomplete+ settings is PRECISELY what I was looking for
love you guys :heart::heart: keep coding

12 Likes
#6

Where is the “Keymap for Confirming a suggestion” setting ?? All I can find is the following:

#7

Look in the settings for the autocomplete-plus package.

1 Like
#8

great thanks

#9

Literally was looking everywhere for that little beauty.

#10

FWIW, I think “tab always, enter when suggestion” is the better default here. I use “enter” alot, and not often for autosuggest.

1 Like
#11

This makes autocomplete in Atom actually usable. Thank you.

#12

i agree something like the “tab always, enter when explicitly selected” would be good for a default option.

tab and enter always almost made me leave atom

1 Like
#13

Realized this package is already bundled with Atom so just cmd + shift + p, then search for installed packages, then search for autocomplete-plus, then click settings:

1 Like
#14

Thanks! Awesome software. I don’t do computer programming, but I do write creatively. This is currently my favorite way to write. Using project folders allows me to provide the same sort of organization as something like Scrivener, while still using plain text to write so the files themselves are better protected from corruption when archiving.

Love the look and how easy it is to use. Thanks everyone!

2 Likes
#15

Where do you uncheck, “Show Suggestions on Keystroke”?

#16

Follow the screenshot posted above. Settings, then Packages, and open the package-specific settings.