How do I disable autocomplete confirmation for certain keys?


#1

This code isn’t working, i.e. enter still confirms.

'atom-text-editor.autocomplete-active':
  'enter': ''

I don’t see a lot of autocomplete-related keys in the keybindings menu. They seem to be missing.

How do I work this out?


#2

You can open the Settings View using Cmd+, on macOS or Ctrl+, on other platforms. From there you can navigate to the settings for the autocomplete-plus package by clicking the “Packages” tab, searching for “autocomplete-plus” and clicking the Settings button. When you’re there, you can find this setting:

And configure it like I have to use only Tab.


#3

That works great! Thank you.