How can I run an interactive python console of python in ATOM?


#1

I used sublime text 2 for a while and I was used to the sublimeREPL extension. It allowed me to give it input into the editor. I was wondering if there was a package for ATOM which can take input from the user. any ideas?


#2

Since Atom is built on web tools rather than Python, Atom has the standard Chrome Developer Tools including an interactive JavaScript console. You can get to the Developer Tools by using Cmd+Shift+I on OS X or Ctrl+Shift+I on other platforms.

If you’re needing a Python REPL, the hydrogen package may cover what you’re looking for.


#3

Sorry for the VERY late reply, but I want an interactive python2 repl (which can take input). Isn’t there any package that can do that? I’ll even take a package that just opens up a terminal in the directory of the file so that I can run the file from the terminal.


#4

There are a few terminal packages. With there being over 3,400 packages now, it is hard for me to know every single one :grinning:


#5

@CabbageHead_360 did you find python console you were looking for?


#6

No I did not, but I found terminal-plus. I just use that to run code


#7

Run a python source file in a Linux Terminal with python-run-terminalnx package


#8

such a shame nothing like this still exits on atom


#9

Someone has to make it before it can exist. I’m sure a Python REPL would benefit many people, but the way these things come into existence is when one or more people who are going to benefit from the package existing get down to figuring out how to make it. If you aren’t confident in your ability to write it, you can still get the ball rolling by opening a GitHub repo with a specification document and shop around for collaborators who can help design the package itself.


#10

@DamnedScholar
The best way I’ve found to easily run a python command with a keystroke is the following plugin

Others will work fine but most will not accept input properly.

You can modify the source of the plugin very easily from the atom interface to support python 2 or 3.