How can I disable core key binding?


#1

Hello. I have weird issue with disabling core key binding. I have already searched around, and figured out ‘unset!’ and ‘native!’ but that didn’t helped (or I have misunderstood something).
The thing is when I want to type [ character on my keyboard, for example I have to press Ctrl+Alt+F or Apps/Alt Graphic+F key combination to type [ in Notepad. Now this is where my issue starts. I’m running Windows 10 TP x64 bit, and latest Atom build.
I’ve tried editting my keymap.cson file to this:

‘atom-workspace’: # atom-text-editor:not([mini])
‘ctrl-alt-f’: ‘unset!’
’.platform-win32, .platform-linux’:
‘ctrl-alt-f’: ‘unset!’

And saved the keymap file, then restarted Atom. Created a new file, plain text. Now I tried to type [ character, and guess what happened? Line got folder or it would bring up find and replace box…
Also I tried using ‘native!’, ‘’, ‘null’, etc. and restarting Atom… Nothing of that kind worked. No errors reported from Atom (except when I used ‘’…)
Please tell me how do I fix this as soon as possible.

P.S. I have also noticed that shortcuts/text that displays in the middle when no files are opened… are wrong.
Do You developers know there is not only one national keyboard?


#2

This sounds like:


#3

Drama. But, this. Could you tell me how do I fix it using that kind but for my case?
As I am unsure what [ translates to…


#4

You enable the keybinding resolver and then hit the key.

I wish I recalled how @leedohm wrote keybindings… google… clickety click… Ah!

Ctrl+. on Windows I guess and Cmd-. on OSX.

(Lee, do you write plus for Windows and minus for OSX, as in Ctrl+F versus Ctrl-F?)


#5

I write + for both now. I kind of used + or - randomly before.


#6

Sounds like a similar issue I’ve had the last days … Does this help?


#7

Tried so many options. It still doesn’t work for me. So many trial and errors…
I have 0.211.0 (most recent update as of date of this post). It is very disappointing to see “Fixed an issue where the unset! keybinding override did not work correctly” message in v0.204.0 (2015-05-28) and it is still not completely fixed. Over a year. Really annoying… Is this a common-law feature?!