Horizontal scrolling bug with soft wrap?


#1

When I turned on soft wrap setting, I expect no need for horizontal scrolling on my pane. It turns out, however, the pane is still scrollable horizontally even though there is no characters to show.

If I increase my window width at certain length, it acts as expected.

Do you have any idea of this bug? or how to resolve it?


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?
  • Are you using a proportionally-spaced font?

#3

Sure,

  • atom version: 0.124.0
  • osx 10.10 (preview 2)
  • I can reproduce it in the safe mode
  • I am using a monospace font: Menlo, but I can reproduce it using default font Monaco.

It is easy to reproduce. Please refer: http://pastie.org/9522131

  • Create a new file.
  • In a line, put one word followed by about 80 space, and put another word in the end.
  • Turn on soft wrap and try various window sizes.
  • You can horizontally scroll it.

#4

Confirmed in OS X 10.9.4. Can you file a bug on this and link it back here?


#5

Thanks for checking. I will file the bug. Have a good one.


#6

Filed: https://github.com/atom/atom/issues/3437