Horizontal scroll overlays last line of file buffer


#1

I would imagine that this has probably already been reported, however, this one irks me since I regularly work in legacy code that could be both beyond the line length specified (and softwrap can be detrimental when trying to resolve line length issues) and the files are particularly lengthy. When you have this cosmic storm of mishaps in old code, the horizontal scroll at the bottom of the buffer overlays the last line of the file. Sure, this could be rectified by simply adding a blank line at the end for the scrollbar to be placed over, but that seems a rather crude way to work around the situation.

Since I can’t seem to paste an image of what I’m talking about:


#2

Yep I’m getting the same thing.


#3

I think Atom expects that you use hidden scrollbars, which are enabled by default when you have a trackpad. As a workaround, this might work:

System Preferences -> General -> Show scroll bars -> When scrolling

But obviously this changes all scrollbars for all apps, which is less than ideal.


#4

Try this package.

http://atom.io/packages/scroll-past-end


#5

Although that package removes the symptoms, the weird behaviour stays a bug.

I have scrollbar hiding turned on, but connecting a non-Apple mouse cancels that setting.


#6

Yep. Ditto here. This is clearly a bug. Atom shouldn’t assume the user is always on a trackpad, nor should I have to change a system-wide setting to fix this.