Hitting space bar in search field results in 'page down'


#1

Hitting the space bar inside a search box (e.g. when searching for packages) will result in the entire page being shifted as if you hit page-down. This would make sense if the cursor is not blinking in the search bar, similar to what occurs when using Chrome normally; however, when the cursor is in the search bar this behavior is unnecessary - borderline aggravating.

Is there a way to turn this feature off, or make Atom more responsive to whether the cursor is in the search bar or not?

Cheers,
Chris


How to disable scroll when press spacebar
#2

This is a known issue. One user has provided a fix that can be put in your init.coffee.