Hide/Toggle menubar


#1

Compiled for linux today, looks as great as mac application

One question though, does anybody sit on any trick to hide the menubar?
I usually edit with just the editor window, command palette is more than enough and don’t really need the menubar taking up valuable estate

I have searched and did not find this question asked before.


#2

It’s called tree view in the command palette where you should also see the command (shift+cmd+p on mac)


#3

Treeview is the fileview on the side, right?

I’m talking about the menubar (File/Edit/View/…) along the top below titlebar (or top of the screen on mac).


#4

I have a semi related issue. I installed using a debian package that I built the other day. While working in atom the menu bar disappears. If there is a show/hide command maybe it will show up again but I have not found the command yet. I have not been able to identify what makes the menu disappear yet. I am starting to suspect it is after I open the settings dialog. I am currently getting an error in the settings dialog so perhaps the error is making the menu disappear.

I realize the error I described is not directly related to the OP. But the image I uploaded is the view I think you are looking for. If there is a toggle command for this maybe both our questions will be answered.


#5

That is excactly what I’m looking for :smile:

Maybe I could go to settings back and forth until your issue is reproduced :wink:

But more seriously, a menu-bar toggle would be nice, I have started looking at the code where application-menu is built to see if there is an easy way of lifting it away


#6

I’m also looking for option to hide menu bar ( using atom from i3 wm )


#7

What seems to have worked for me is choosing ‘View > Toggle Fullscreen’ a couple of times, although now I don’t seem to be able to restore the bar to test it.


#8

I’m here for this too. Work under stumpwm. I like minimalistic look of my Emacs and this is critical feature for me, so, no true zen in Atom :slight_smile:


#9

+1 is there an option to hide the menubar (file, edit,…) ?


#10

Im on a mac so I cant really test this. but have you tried to select the menubar using “Developer tools” (F12) ??

if it has a id you can make a display:none in your Stylesheet


#11

yes, the menubar isn’t part of the “html rendered area” so you can’t use the inspector on it.
I’ve found the menubar.visible # true property but i’m not able to override it to false


#12

I’m also looking for this feature to be implemented, particularly now that the latest build looks like this (big white bar):


#13

on my linux build currently I rollback to v0.119.0 cause v0.120.0 break some of my plugins.
I usually comment out all lines with ApplicationMenu on application-menu.js file… see gist above…
I wish I can put some package that will inject on application-menu.js to show or hide menubars but I think the menus will be populated during startup of atom so we need to close and rerun atom for it to work…

Files are located at Atom/resources/app/src/browser of your atom package… or different if your on Mac or Win…


#14

If you have a fix, perhaps you could write up a Pull Request for the functionality?


#15

I just accidentally hid the menu bar trying to hide the find window…lol

anyways, i remember the old notepad (windows) command, so try “ALT” key
that brings the menu bar back (with an auto hide type feature) then just do
"VIEW -> Toggle Menu Bar" again & it will stay.


#16

Hey buddy thanks a lot. I was scratching my head while hacking on https://www.megam.io on our scala code https://github.com/megamsys/megam_gateway.git.

I toggle the toolbar, and your tip on just pressing “ALT” worked for me in archlinux.


#17

I also have the same problem, so i play around a bit on atom (windows 7) & found a way to get it back…

step 1: Click within the red border area & press “Alt” key. you will see the menu bar as shown in following image…

step 2:.Now goto view & select “Toggle Menu Bar” option get menu permanently.

@jaymanale :smile: :smile: :smile:


#19

Thanks!! This fixed an issue i’ve been having


#20

Thank you, it works here. :slight_smile:


#21

A post was merged into an existing topic: Hide treeview by default?