Hide Specific Folders from Tree View / Fuzzy Search


#1

It’d be nice to have easily configurable options to hide folders from the tree view and fuzzy search in addition to files. I personally have compiled CSS/JS folders I dont want to be included as part of my folder view and project wide searching.


#2

You can set these up in the “Ignored Names” field of the main Settings section of the Preferences. Once you’ve done that, just check the “Hide Ignored Names” option in the Tree View section of the Preferences (you have to scroll down on the left in the prefs to see this section).


#3

This isn’t a solution to the problem, but I think it would be pretty nice to have an option that looks at your “.gitignore” and correspondingly hides files.


#4

That’s already possible! In that same section there’s a “Hide Vcs Ignored Files” option. :grin:


#5

Oh man, that’s so cool. I’m curious to know if it ignores only the files mentioned in the .gitignore in the root, or even the files in sub-folders. Unfortunately I don’t have an invite to the editor to try it out :frowning:

edit: I just got an invite. this feature works quite well.


#6

Is this option still there? I cannot find it! :frowning:


#7

…“Ignored Names” field of the main Settings section of the Preferences. Once you’ve done that, just check the “Hide Ignored Names” option…

Yes, this works great.


#8

I just started running Atom yesterday (v0.211.0)
Try as a might, i could not see any tree-view settings in the preferences UI
After some more digging and guessing, adding the following in my config.cson did the trick

  "tree-view":
    hideIgnoredNames: true

While writing this, i finally figured out that the tree-view settings are now under packages, search for tree-view, then click on settings. (i tried uploading a screenshot here for each step, but was stymied by discourse … aargh!)
j.


#9

Sometimes I have just a big list of folders at the same level and I need to focus on a subset.

There is nothing similar to a scope o work-set ?


#10

You can just right-click on that folder and choose “Open in new window”.


#11

Couldn’t find the options mentioned to hide ignored files, so I altered my theme and achieved the same result…

add the following to your stylesheet (or your theme): ~/.atom/styles.less

.status-ignored {
    display: none;
}

#12

I turned on “Hide VCS Ignored Files” in settings for tree-view, but I still see all the ignored files. I assume there is a second step required to make it work, but I can’t figure it out.