Hide Atom Title Bar on OSX


Hi all.
I just installed atom.io and discovered a thing that annoys me quite a bit:

When I maximize atom.io with my window manager the osx title bar shows up and takes away space.
Is there a way to hide this title bar? I dont really need the lights in the top left of the bar.
Maximizing the Window by pressing the green button serves my desired look but the osx fullscreen animation sucks imo.

I found 2 discussions already but both of them dont deliver the solution:
Simple Full Screen Mode (when i press shift+option+green nothing happens)
Hide system window title bar


As you pointed out, there is already an open topic on this subject. We like to unify similar discussions under one topic so that people don’t have to read a bunch of different threads to get the whole story. Please continue the discussion there. I’ll be closing this topic as duplicate.

Additionally, a change was recently merged that allows for themes to customize the appearance of the title bar if the user opts in. It should become available in v1.11.x. So while we may not be adding this feature directly, others could in community themes and packages.

closed #3

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.