Help with publishing packages?


#1

I’m having the same problem as well

I’ve published an empty syntax theme and failed several times trying to publish it the right way…


Can't unpublish my theme
#2

The topic you posted on was specifically about unpublishing packages, but you’re saying you are having problems publishing packages? Can you be more specific as to what exactly the problem is?


#3

Quick run down of what happened:

After trial and error several times. I decided to run everything on a brand new repo…

  • created/generated a theme using the cmd+shift+p command.
  • speficied name, version: 0.0.0, github repo, and other details
  • git init
  • git add + commit +push
  • apm login
  • apm publish minor
    – This step is the one that gives the most BS. This is the output all the time
> apm publish minor
Preparing and tagging a new version ✓
Pushing v0.1.0 tag ✓
Publishing light-wave-syntax@v0.1.0 ✗
Creating new version failed: Git tag not found

What I have now is a version 0.1.0 that doesn’t display anything in atom theme page. I tried to unpublish the theme and I was denied access even when I recreated the repo just to remove that blank theme from atom.

I’m currently working/developing the theme for myself as I can’t find one that I like. I’d love to contribute to the community but this step is just such a

So if you can help me that would be great


#4

Sounds like you’re having the same problem as what happened here:


#5

Just read the issue. I think you misunderstood my issue. I don’t get this error… What I get is this

Creating new version failed: Git tag not found

If I do git tag I get this:

v0.1.0

I’ve wiped my repos/deleted them & recreated them just to get rid of the “missing tags”. I also recreate the package.json file just to make sure I’ve got a baseline state. I run the same command apm publish minor again and I get the same error. I’ve tried many different things already.


#6

If you deleted the repository for a package after the package was created on atom.io then you’ve lost access to the package on atom.io. There really isn’t anything you can do at this point until an Atom administrator can fix it.


#7

Are you sure the repo in the package.json file is the right one? I believe apm is looking for that field when publishing and I got bitten several time by the fact that it was using atom as user instead of my username in the repo field, so I had to change that manually prior to publishing.


#8

@leedohm I’ve read previous suggestions to contact an admin so I’ve emailed @thedaniel but he hasn’t replied yet I’m waiting on a response.

@abe Could you give more details… I’m not really following… This is what I have in the package.json file.

{
  "name": "light-wave-syntax",
  "theme": "syntax",
  "version": "0.1.0",
  "description": "Atom Light Wave Syntax Theme",
  "keywords": [
    "syntax",
    "theme"
  ],
  "repository": {
    "type": "git",
    "url": "https://github.com/dannyk08/light-wave.git"
  },
  "bugs": {
    "url": "https://github.com/dannyk08/light-wave/issues"
  },
  "license": "MIT",
  "engines": {
    "atom": ">=1.0.0 <2.0.0"
  }
}

#9

Alright I successfully published a test syntax theme and my failed renamed theme. Everything works. I just wish I could’ve kept the name


#10

hey danny, do you remember what you did? I’m having the exact same problem.


#11

The instructions on how to rename a package are in the Atom Flight Manual here:

http://flight-manual.atom.io/behind-atom/sections/maintaining-your-packages/#rename-your-package