Help with installing packages


#1

Hey, I am new to Atom and I am trying to install packages. It would be great with some help, I put the full error code below when using apm in the command line:

return binding.mkdir(pathModule._makeLong(path),
             ^

Error: ENOENT: no such file or directory, mkdir 'C:\Users\vetle\AppData\Local\Temp;C:\ffmpeg\bin\d-117229-8872-g27k1z'
at Error (native)
at Object.fs.mkdirSync (fs.js:794:18)
at Object.mkdirSync (C:\Users\vetle\AppData\Local\atom\app-1.15.0\resources\app\apm\node_modules\temp\lib\temp.js:137:6)
at Request.<anonymous> (C:\Users\vetle\AppData\Local\atom\app-1.15.0\resources\app\apm\lib\install.js:335:41)
at emitOne (events.js:77:13)
at Request.emit (events.js:169:7)
at Request.onRequestResponse (C:\Users\vetle\AppData\Local\atom\app-1.15.0\resources\app\apm\node_modules\request\request.js:1029:10)
at emitOne (events.js:77:13)
at ClientRequest.emit (events.js:169:7)
at HTTPParser.parserOnIncomingClient [as onIncoming] (_http_client.js:430:21)

#2

The error you’re running into looks very much like the errors mentioned in this post:

It looks like a couple of folks were able to get past the error so you might have some luck checking in there with the users that were able to fix things.


#3

I had exactly this same issue and i was able to fix it from and earlier thread @ <Packages not working> Error: ENOENT: no such file or directory, mkdir

The basic thing here is just to edit your Environmental variables and TMP and TEMP to %USERPROFILE%\AppData\Local\Temp. This worked for me


#4

Thank you so much for this. It worked finally.

But I would definitely want to why this issue could have risen.