Help! A fellow noobie

3186 verbose node v10.2.1
3187 verbose npm v6.2.0
3188 error code ELIFECYCLE
3189 error errno 1
3190 error pathwatcher@8.1.0 install: node-gyp rebuild
3190 error Exit status 1
3191 error Failed at the pathwatcher@8.1.0 install script.
3191 error This is probably not a problem with npm. There is likely additional logging output above.
3192 verbose exit [ 1, true ]

Im a utter noobie here but im unable to install anything within the compiler
any help would be appreciated.

This doesn’t appear to be a question about Atom or Electron. If this is a question about Atom or Electron, please give some more information so we can understand better.