Having issues installinh Platformio

This is the error it is Generating:

Installing “platformio-ide-terminal@2.9.4” failed.Hide output…

node-pty-prebuilt-multiarch@0.9.0-beta21.legacy install C:\Users\narya\AppData\Local\Temp\apm-install-dir-119717-16056-l0vi24.rshf8\node_modules\platformio-ide-terminal\node_modules\node-pty-prebuilt-multiarch
prebuild-install || node scripts/install.js

C:\Users\narya\AppData\Local\Temp\apm-install-dir-119717-16056-l0vi24.rshf8\node_modules\platformio-ide-terminal\node_modules\node-pty-prebuilt-multiarch>if not defined npm_config_node_gyp (node “C:\Users\narya\AppData\Local\atom\app-1.40.0\resources\app\apm\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Users\narya\AppData\Local\atom\app-1.40.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” rebuild )

prebuild-install WARN install No prebuilt binaries found (target=3.1.10 runtime=node arch=x64 libc= platform=win32)
gyp ERR! configure error
gyp ERR! stack Error: Can’t find Python executable “C:\Users\narya\AppData\Local\Programs\Python\Python37\python.EXE”, you can set the PYTHON env variable.
gyp ERR! stack at PythonFinder.failNoPython (C:\Users\narya\AppData\Local\atom\app-1.40.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\lib\configure.js:492:19)
gyp ERR! stack at PythonFinder. (C:\Users\narya\AppData\Local\atom\app-1.40.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\lib\configure.js:517:16)
gyp ERR! stack at C:\Users\narya\AppData\Local\atom\app-1.40.0\resources\app\apm\node_modules\npm\node_modules\graceful-fs\polyfills.js:284:29
gyp ERR! stack at FSReqWrap.oncomplete (fs.js:182:21)
gyp ERR! System Windows_NT 10.0.17763
gyp ERR! command “C:\Users\narya\AppData\Local\atom\app-1.40.0\resources\app\apm\bin\node.exe” “C:\Users\narya\AppData\Local\atom\app-1.40.0\resources\app\apm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd C:\Users\narya\AppData\Local\Temp\apm-install-dir-119717-16056-l0vi24.rshf8\node_modules\platformio-ide-terminal\node_modules\node-pty-prebuilt-multiarch
gyp ERR! node -v v10.2.1
gyp ERR! node-gyp -v v3.7.0
gyp ERR! not ok
npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\narya\AppData\Local\Temp\apm-install-dir-119717-16056-l0vi24.rshf8\package.json’
npm WARN apm-install-dir-119717-16056-l0vi24.rshf8 No description
npm WARN apm-install-dir-119717-16056-l0vi24.rshf8 No repository field.
npm WARN apm-install-dir-119717-16056-l0vi24.rshf8 No README data
npm WARN apm-install-dir-119717-16056-l0vi24.rshf8 No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! node-pty-prebuilt-multiarch@0.9.0-beta21.legacy install: prebuild-install || node scripts/install.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-pty-prebuilt-multiarch@0.9.0-beta21.legacy install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\narya.atom.apm_logs\2019-08-17T17_43_11_708Z-debug.log

The same question has been asked and answered numerous times. Search is a great feature all across the internet.

I also faced the same issue. To fix this do the following
1.Open powershell with admin access
2 npm install --global --production windows-build-tools Execute this

A fix for this error has been released with 1.40.1, could you confirm it works now?

1 Like

Confirmed, the Update fixed it!