Haskell: vertical alignment, visual vs. actual


#1

EDIT 6 hrs later:
If I simply start a new line after “let” and “in” things line up OK, and this is fine.
Lastly, I think my post is rather nitpicking. It’s OK to close it.

Cheers :slight_smile:


First post here. Happy to say I’ve been enjoying Atom very much. Recently began learning Haskell and came upon this minor problem that, nevertheless, will result in a compile error.

Running Atom 1.21.0x64 on Debian 9.2.0
Relevant, IMO, Installed packages:
atom-justify 0.4.1
ide-hasekll-hoogle 0.1.2
language-haskell 1.16.2
language-haskell-scoped 0.1.0

The snippet below shows how sideArea and topArea ought to appear since both start on column 13. But topArea appears one space to the left, as though it is in column 12. (This doesn’t happen on a text editor or, as I found out in this message box.)

let     sideArea = 2 * pi * r * h
        topArea = pi * r ^2
in      sideArea + 2 * topArea

EditorSettings are default, meaning that the four blue check boxes starting with Atomic Soft Tabs are checked.

I’ve tried disabling the the three Haskell packages above, opened a new file, which of course lacked the colors, typed in the above snipped and saw the same behavior. The line in between the “let” and the “in” is visually indented by one space although it is actually the same as the others.

Can Atom be configured to avoid this problem?
If not, OK but then the question is, how do I configure Atom to run in a plain Jane text editor mode, which of course doesn’t have this problem, for only the Haskell .hs files while leaving the C .c file settings, editor and compiler, alone as they work well.