Haskell-ide hover to show type does not work when running in docker container


#1

I’m running atom in a docker container

I’m logged into the docker container using ssh and the X output is being sent
back to the host machine so that the editor displays on the host. This is working fine. For the most part things seem to be working fine.

However, there’s a feature called “hover to show type” that is not working. What this feature does is that when you hover the mouse over a variable its type appears in a temporary box over the variable.

The editor does know about the presence of the mouse in general. When I get syntax errors those show up as little triangles and I can hover over those to see more information so “mouse hovering” in general seems to be working.

I have tried running atom on the host machine and that works fine.

I checked the settings and the “hover to show type” feature is enabled.

Any thoughts on what the problems might be? I don’t have a immediate good way
to try running atom from a non-docker X client or I would have tried that
already.

EDIT: I was able to install haskell and atom on a remote linux machine and run atom with the window displaying on my local machine. In this case, “hover to show type” works fine. So the problem may be something docker specific

EDIT: Cross posted to stackoverflow : http://stackoverflow.com/questions/31525617/hover-to-show-type-does-not-work-in-atom-haskell-ide-running-in-docker
Thanks.