Hardly anything works (1.21 beta) after install


#1

I’m running on Debian 8 (LMDE - Linux Mint Debian Edition) and uninstalled 1.5.4 in order to try the Atom IDE. I’ve installed the .deb package for 1.21 beta and get all the menus and a blank window. If I choose Help > About: nothing. Other commands: nothing. File > New Window creates a new window, but nothing is ever displayed in the main editor window area, and I mean nothing other than the background.

I see that others have had similar symptoms, but a) I’m not running a VM, and b) the issue with v1.19 beta appears to have been fixed *.

Maybe that fix has been undone, but I tried the diagnostic suggestion * (atom --foreground) from the topic on v1.19 beta but it doesn’t appear to be the issue (or I’m not doing it right):

$ /usr/share/atom-beta/atom --foreground
bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell

Any ideas? I’d like to try out the Atom IDE, but ok without Atom so not a pressing issue for me.

[* As a new user I’m limited to two links, so here are broken URLs for the asterised fixed * and diagnostic suggestion *:
diagnostic: https:// discuss.atom .io/t/atom-1-19-beta-wont-load-fully-in-linux/44066/3?u=happybeing
fixed: https:// hosunghwang.wordpress .com/2015/07/15/libstdc-so-6-library-mismatch-problem-and-solution
]


#2

Hi @happybeing,

Do you mean that you had Atom 1.5.4 running before upgrading to Atom 1.21 beta? There might be issues when upgrading from an older version. Specifically you might be running an old community package that does not work correctly with the new version or there is some changes in the saved state that did not update correctly. Have you tried the steps listed in the flight manual debugging section http://flight-manual.atom.io/hacking-atom/sections/debugging/

I think you should try running safe mode, clearing saved state and resetting to factory defaults. Please note that clearing saved state will result in a data loss for any unsaved buffers you have across all Atom projects.


#3

Thanks @Ben3eeE, --clear-window-state has done the trick.