Grammar selector default language


#1

Hi there,

I’m working on a React Native project on Mac OS.

Few days ago, the default grammar language changed, I’m not able to see my code clearly.

I think, it switched from “Javascript (rails)” to “Javascript” because when I do cmd + shift + L, I see Javascript is selected but the “correct” color is “Javascript Rails”.

Do you know how to change the default grammar syntax for Javascript?

Thanks,


#2

If you recently updated to Atom 1.32, it sounds like you’re running into the same issue as this one (as a result of Tree-sitter being enabled by default):

One of the options mentioned in How to default to language-babel should help.


#3

Yep, thanks!