GPP-Compiler Issues?


#1

So I’m trying to learn C++ right now through some video tutorials and such. And I was getting some addons in Atom so I could possibly run the C++ through the compiler and such. So I installed like directed in gpp-compiler of MinGW. Installed the C++ compiler. And when I run the code I get this error in the upper right-hand corner.

As you can see I get that error. I honestly don’t know what to do next and that’s why I’m here. I tried looking online and some say try putting gcc in command prompt, but I get the usual “gcc is not recognized” error. And others say that if you get that error, go and set the “PATH”, but I don’t know where the path would even be for the gcc compiler.

Anyway, I hope I can get some help here to clear this up. I really like Atom, very flexible and customizable. On the tutorials that I’m learning from they use all sorts of different ones, and I honestly don’t want to download them. Rather stick with Atom.

Thanks!~


#2

From the MinGW Wiki:

  • Determine which files below you need and download them.
  • Extract the files into a directory such as C:\MinGW
  • Add C:\MinGW\bin; to the PATH environment variable.

Microsoft got you covered on how to do that (works the same in Windows 10)


#3

Well, I just figured out my own issue here. It turns out that I had C++14 on (from a add-on in Atom I think). And when I changed the displayed Code to just C++. The Terminal ran like it was supposed to.