GLIBCXX_3.4.20 required by apm


#1

Hi,

I am running Atom 0.194.0 on Centos 7 and have a problem using apm.

Apm crashes with the following error:

/usr/share/atom/resources/app/apm/node_modules/asar-require/node_modules/asar/node_modules/chromium-pickle/node_modules/bindings/bindings.js:83
    throw e
          ^
Error: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/share/atom/resources/app/apm/node_modules/asar-require/node_modules/asar/node_modules/chromium-pickle/build/Release/pickle.node)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at bindings (/usr/share/atom/resources/app/apm/node_modules/asar-require/node_modules/asar/node_modules/chromium-pickle/node_modules/bindings/bindings.js:76:44)
    at Object.<anonymous> (/usr/share/atom/resources/app/apm/node_modules/asar-require/node_modules/asar/node_modules/chromium-pickle/lib/main.js:1:99)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)

It appears that apm depends on a very recent version of GLIBCXX. Centos 7 only provides GLIBCXX up to 3.4.19.

Could it possibly be linked with an older version with more widespread availability? Or optionally offer an rpm/deb which are statically linked?

Best regards,

Alastair