.gitignored files hidden regardless of hideVcsIgnoredFiles and hideIgnoredNames


#1

Continuing the discussion from [.gitignored files are hidden from tree view regardless of setting]
(.gitignored files are hidden from tree view regardless of setting):

Setting the following in config:

hideIgnoredNames: false
hideVcsIgnoredFiles: false

Or by disabling the equivalent checkboxes in Settings, I am still not seeing my gitignore’d bower_components… How to fix?


#2

Just adding:

hideIgnoredNames: false
hideVcsIgnoredFiles: false

to your config.cson doesn’t necessarily do anything. These have to be in the correct section of the file, i.e. underneath tree-view which is underneath *. In actuality, it is easier to just delete any lines mentioning hideIgnoredNames or hideVcsIgnoredFiles because false is the default. If there is no line for these settings … then Atom assumes they’re the default, which is false.

Try this:

  1. Completely exit from all instances of Atom
  2. Rename ~/.atom/config.cson to ~/.atom/config.cson.backup
  3. Start Atom again

Do your .gitignored files show up?


#3

Thanks for your reply–yes, I had them in the right place.

Apparently my problem was just that the package “git-hide” I had installed was either not working properly or maybe I had typed the wrong key combo for it or in the wrong place or something… Anyways, it’s working now, thanks!