GIT: Unstaged changes not showing up


#1

Hey I 'm new here :slight_smile: and sorry for my bad english :sweat_smile:

So I have a strange problem with any version of atom (currently using the latest version + latest git version). So I worked on a school project on github. the project is already quite far, I cloned it within atom. Now when I make changes in the index.php file and any other files, no files that got changed show up on the unstaged changes git panel. but the file that got changed is orange now.

Now the strange part, if I make a fresh repository and clone it within atom and create a new index file and change something it will now show under unstaged changes, so in that new repository it’s working fine!?

Can someone help me, or has any idea what the problem could be?
thx for any answers :slight_smile:


#2

also if I make changes to a file, it shows me on the right bottom corner that a file or multiple files got changed, when I click on it, the unstaged changes don’t show up. and again, on the fresh repository it works as intended. :slight_smile:


#3

Hey,

There is currently an issue where unstaged changes don’t show up correctly if there is a space in the path. Do you have a space in the path of the repository that isn’t working?

Issue ref: https://github.com/atom/github/issues/1177


#4

thx for your fast answer,
which path do u mean or what do u mean exactly with path? :sweat_smile:


#6

you mean that the file names in the repository have spaces in it? if so, non of my files have spaces and it’s not working in that old repo only the fresh one works just fine :confused:


#7

Hi,

I think this could also happen if the directory where the files are located has a space in it.

Do you see any errors in the developer tools console? You can open the developer tools from the “Developer” menu.


#8

nope no spaces in the directory/folders

and here is the console log with an error of that repo, where the unstaged changes not showing up, but that doesn’t mean anything to me :sweat_smile: :confused:

dffdsasdasdsad


#9

Hi,

Looking at this it seems that it says that HEAD is both a revision and a filename. Do you have a file with the name HEAD in your repository?


#10

yes in that repo is a file called Head.php, could this be the problem? because I worked with VS Code, for that time, because atom wont show me the changes and in VS Code it works just fine? :slight_smile:


#11

^^ I always click the wrong reply button :sweat_smile: :joy:


#12

I just noticed in that repo is also a file named HEAD from type file and it contains the following: ref: refs/heads/master
I deleted it and now it works. Is this file important? I don’t know who or what created it? :sweat_smile:


#13

If you didn’t create the file and it was in your repository (and not the HEAD file from .git/), then our guess is that the file was accidentally copied from the .git/ directory and is safe to delete.