Git Plus Not Pushing Properly?


#1

Hi all!

So I recently signed up for Github and started coding in ATOM.

I installed GIT PLUS last night and had issues setting it up. I finally managed to in my Ubuntu 16.10. When I did I tried to do these:

Git All
Git Commit All

During commit I noticed that .git was in my /documents and had included my hidden files. I deleted .git there (I have .git in the folder I have my codes written into) and tried to use ATOM again for the same purpose. When I redid Git All (With a change or two to my code) my text wasn’t highlighted. So I didn’t mind it, tried to commit and push. During push it asked me for my repo. So I went to the folder the code was on, launched a terminal, entered my repo (git remote add thingy).

When I returned back and tried to push it again but it didnt ask me for my pass or username; yet it said success.

I had to push manually…

How can I fix this? I want to be able to push within ATOM…


#2

You should probably follow up with the maintainers of the package. The Atom FAQ has information on how to contact the maintainers of any Atom community package or theme.


#3

I already did but I made this thread to ask if anyone knows a fix or something? I hate to do the manual…

Also can I piggyback this to ask a small question? How can I edit my commit after I pushed it? I made a typo so…


#4

The random people here are much less likely to know how to fix the problem than the person who designed the package.

It’s possible, but usually not worth it.


#5

Thanks.

I managed to edit my commit after getting help from some fellas in Discord who helped me fix some issues in SSH and what not. I am still waiting for a response from the dev and I think I got a partial/temp fix for it so…


#6

There actually isn’t a way to edit commits in Git. Even the git commit --amend command doesn’t edit the commit, it replaces the old commit with a new one that looks like the old one plus your new change. You can prove this by looking at the commit ID (also referred to as a SHA or hash):

[~/Source/test] git init
Initialized empty Git repository in /Users/Lee/Source/test/.git/
[master][~/Source/test] touch test.txt
[master][~/Source/test] git add .
[master][~/Source/test] git commit -am "Initial commit"
[master (root-commit) 79b048e] Initial commit
 1 file changed, 0 insertions(+), 0 deletions(-)
 create mode 100644 test.txt
[master][~/Source/test] touch foo.txt
[master][~/Source/test] git add foo.txt
[master][~/Source/test] git commit -m "Testing"
[master f47a3a2] Testing
 1 file changed, 0 insertions(+), 0 deletions(-)
 create mode 100644 foo.txt
[master][~/Source/test] git log --graph --decorate --pretty=oneline --abbrev-commit --all
* f47a3a2 (HEAD -> master) Testing
* 79b048e Initial commit
[master][~/Source/test] git commit -m "Testing ... no really" --amend
[master b325624] Testing ... no really
 Date: Sun Oct 23 09:09:07 2016 -0700
 1 file changed, 0 insertions(+), 0 deletions(-)
 create mode 100644 foo.txt
[master][~/Source/test] git log --graph --decorate --pretty=oneline --abbrev-commit --all
* b325624 (HEAD -> master) Testing ... no really
* 79b048e Initial commit
[master][~/Source/test]

Notice the commit ID for the first “Testing” commit is f47a3a2 but the second one is b325624. You’ve rewritten the Git commit history. Why is this important? Because doing this on your own local repo before you push to a remote repository is fine. If you rewrite the Git commit history after you’ve shared your changes with other people, things can get … messy :slight_frown:

Then again, if you’re the only one using your remote repo … go ahead, knock yourself out! (You’ll need to use git push --force to force the remote repository to accept the history rewrite.)