Git-Plus issue initial commit


#1

Hey,

I’ve got an issue using the git-plus addon, and hope you can help me.
When I start creating a new git repo, with the following workflow:

  • Git Plus Init
  • Git Plus Add
  • Git Plus Commit
    I get an error-message at the third step, the commit:
    fatal: abiguous argument 'HEAD': unknown commit or path does not exists in working directory: Use '--' to separate paths and commits...' (translated from other language, hope its correctly translated :wink: )

When I do this steps without atom and git-plus, directly in terminal, everything works and after that I can use Atom and Git-plus for the next commits.

Have you an idea, how I can solve this and also do my first commit inside atom?

Thanks and best regards


#2

Sorry, forgot to say using current Xubuntu 18.04 release.


#3

Does it matter what project you work with? I created a directory with a single test file (just “Hello World” in it), opened it in Atom and ran init, add, and commit with Git Plus and it worked ok. If you try a test project do you still get that error?


#5

Thanks for your feedback. I’ve also tried it with a new test project, as like as you said, but still the same error. It seems that it doesn’t create the master file in /refs/heads/.


#6

Curious if you have the same issue using the built-in GitHub package to initialize a repository?

https://flight-manual.atom.io/using-atom/sections/github-package/#initialize-repositories