Git-plus has turned unresponsive


#1

I just played around with the git-plus package (which is promising), and I think I somehow screwed it up.

It now won’t do anything. Once I restart Atom, it will let me do one git thing (like git add), but there’ll be no feedback (and no add!), and now git-plus doesn’t even show up in the command palette any more.

Git still works (in Sublime Text, with other plugins).

Oddly, atomatigit also won’t work.

Bug? My stupidity? (probably).

@akonwi, any thoughts?


#2

Can you run atom --safe and uninstall fro settings?


#3

thanks @AbeEstrada; yeah, I can run atom --safe and uninstall; did that, but won’t solve the problem.

Did a couple of un- and re-installs, to no avail.

Also disabled all non-atom packages.

What could possibly be going on here?


#4

I’m sorry your having issues @maxheld83. I did include a bunch of pull requests being merged in an update last night. Perhaps something broke internally while I was doing that.

I’ll see if I can replicate the issue. In the meantime, if it is the upgrade you can revert back to a previous [version] (https://github.com/akonwi/git-plus/releases/tag/v2.7.3) by replacing the current git-plus folder in ~/.atom/packages


#5

I haven’t tried git-plus yet.
automatigit never worked for me, never did a thing when I tried.

I’m not quite clear about why there can’t be simple context menu entries in the treeview to perform git commands. Is this a technical restriction of the atom shell or something?


#6

@akonwi thanks! That did the trick – the old version works just fine. Should’ve thought of that.
Thanks for the fantastic work!


#7

@batjko I’m kinda glad to hear that I’m not the only one who couldn’t figure out automatigit. It seems like a nice idea …


#8

@maxheld83 I published a patch to git-plus. When you update, you may need to run the update package dependencies command in the command-palette if it doesn’t work at first.


#9

Works for me, thanks.


#10

thanks @akonwi great! update package dependencies failed for some reason, but git-plus is up to date, nonetheless and works fine. (the package updater might have taken care of that).


#11

The Update Package Dependencies package is designed to assist package developers, not package consumers. The reason why it failed is probably because you didn’t have an Atom package project open. apm already updates the package dependencies on install.


#12

@leedohm thanks so much. Indeed, I am unfortunately not a developer.