Git-diff doesn't work


#1

Hello everyone,

for some reason git-diff stopped working and I can’t pinpoint the exact time it happened… It was probably around the update from 1.29 to 1.32, when my theme also broke due to Tree Sitter Parser (it’s not the source of error this time :wink: ).

The colored indication of changed/added/deleted lines is not showing anymore. Looking at the diff view (“Staged Changes”), everything looks normal, so the basic diff-ing seems to work. It’s just those indicators missing.

I have installed:
Ubuntu 17.10
Atom 1.32.0
git-diff 1.3.9

I read the similar topics to this question, which are suggested while I’m writing this, and searched DISCUSS already, but to no avail.

Any ideas what stupidity of mine is preventing me from getting this to work again?

Thanks!


#2

Hmm, that’s interesting that it stopped working after an update - can you share exact steps to reproduce (ideally with a minimal test public repository)? A GIF/screencast might be helpful too.

And do you see the same behavior in safe mode?

Lastly, if you install a version of Atom where you remember things worked for you, do the status indicators start working again?


#3

Hi rsese,

thanks for your reply. In safe-mode I see the same behavior, namely that I see nothing :wink:
I just recognized that the coloring in the project-tree for changed files is also not working.

I don’t know what to write to reproduce this. I’m not doing anything (I know, that stupid sentence which can’t be correct… :wink: ), coloring and indicators just don’t show up. I don’t get error messages or something that I could trigger somehow.


#4

So, it’s working again for some weird reason. Here’s what happened:

I realized that the first project in the project tree was colored correctly (apparently NOT depending on the multiple restarts that I did). When I checked, also the line markers where present.

Guess what: The ordering in the tree matters.

The first (timely and position-wise in the tree) project that randomly worked again (let’s call it A) is now colored correctly including line markers. I moved the NOT working project B above A and B is now working. Now comes C. When I move the not working C to the top, it keeps to not work, B also stops working, and A is still fine. Move C back to third position and A and B are working, C doesn’t.

So, all in all: C mustn’t be above B to have B work fine. A seems to always work now. C still doesn’t work. My head is hurting, but I don’t care anymore. Whatever is going on here, I’m going to ignore it, as long as A and B are ok. Introducing D? Not in the near future :unamused:

Thanks anyway @rsese


#5

Wow, thanks for the details @Steffen I’m glad you at least figured out how to get things working again - if I can reproduce based on your description I’ll open an issue and link it back here.