Git Diff does not seem to be working at all


#1

I am assuming it’s Git Diff but it’s not showing any changes in gutter or folder colors when I edit git files/folders. It shows my project as a folder and not as a project as well.

Any help would be appreciated. Thanks!


#2

Sounds like a dupe …


#3

Doesn’t work on any project, it used to work but stopped. I fresh installed and still not working. Nothing within my file structure changed.


#4

Did you check to see if the package is disabled? Did you add a custom theme that makes the annotations invisible?


#5

I am having the same issue. Earlier today folders in the tree view were colored indicating the changes I made, but now they are not. Tried relaunching atom, restarting the computer, etc. Still not working. Also disabled/reenabled the git diff package.

Perhaps related, fuzzy finders shift+cmd+b (toggle-git-status-finder) does not work either.


#6

@leedohm Package is enabled, and I did a clean Install of Atom and only have the packages that come pre-installed installed.


#7

Is anyone else having this problem? It’s making Atom unusable. Nothing is working correctly… includes git gutter, folder highlighting, repo detection and fonts.


#8

bump— sorry, this makes atom unusable and I can’t find any viable ways to fix it.


#9

Still not working for me as well.


#10

Reinstalling atom seems to have fixed the folder highlighting but not the gutter for me.


#11

Have you the Use React Editor option enabled in the editor settings?
The gutter API have been disabled when React is enabled.


#12

Indeed I was! And in fact a bunch of issues I’ve been having went away when I disabled it. Wonder how long ago I turned that on. Thanks!


#13

How did you re-installed atom? I am having problems uninstalling it and trying to re-install it since my git diff is not working.


#14

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

I can almost guarantee the issue that you are running into is not an installation issue. Most likely it is because you are not opening the root directory of your Git repository.


#15

Lol. the problem was exactly what you suspected:

Most likely it is because you are not opening the root directory of your Git repository.

I guess the problem was that git diff doesn’t work the way I thought it did (unless its a bug I guess). I have one src “master” directory with 4 different directories, but each one has a different git repo. Thus, it only gif diffs if I open from the root of each directory. But that kind of sucks because the whole point (for me at least) was to track them with different repos and connected them as I wanted. So is this an expected behaviour?


#16

At this point, yes. You can track the Issue here: https://github.com/atom/atom/issues/770


#17

Just to clarify, when you mean yes, you mean yes, its a bug, i.e. it should work with multiple git repos even if its open from somewhere else? (thats what I infer from the link and the conversation in the gitissue)


#18

Specifically I meant that, yes, it is expected behavior. Whether or not it is a bug depends on your definitions. I believe the New Hacker’s Dictionary would categorize this as a misfeature.


#19

I’m in the top level folder and it has to save it first, then it will show code change in git.