Git core editor


#1

setting atom as default git editor and this is the error I get error: - There was a problem with the editor ‘atom --wait’.

git config --global core.editor “atom --w”

this was the command I used to set atom and it’s getting frustrating . tried everything. I need held guys


#2

What does the core.editor setting in .gitconfig look like? Does it work with other editors? Is git able to open Atom if you remove the --w switch?


#3

yeah I tried removing the --w . still didn’t work. replaced ‘atom’ with it’s full path to get around it somewhat