Gigantic left gutter fix?


#1

So, when I first started using atom it was fine, but periodically the left gutter(the space between the line count and where you cah start typing in the text editor) would become huge, Sometimes I could get it to reset by changing themes, but not any more. Is there anyway to fix this? Is there anyway to just reset my atom configuration and seeing if that will work? I tried uninstalling atom and reinstalling with the beta version, but clearly it didn’t even delete anything that was important to me. What should I do?


#2

Rename the .atom folder to something else. All saved settings and state information are in that folder.


#3

Yup. That fixed it. Thanks.


#4

That’s the brute force way to figure out if it’s something in your local configuration or saved state information. You can figure out if it’s a package by starting Atom from the command line with atom --safe. It’s entirely possible that some state information got in a bad spot, so you should move any packages to the new folder and see if the gutter behaves as expected.


#5

Thanks. I’ll try that out if it happens again.