Getting Error in installing packages

Whenever I try to install any package, it keeps failing and shows this message:

Installing “gpp-compiler@3.0.7” failed.Hide output…
fs.js:143
    throw err;
    ^

Error: ENOENT: no such file or directory, mkdir 'C:\Users\kulje\OneDrive\DOCUME~1\temp\DRAGON~1\DCUPDA~1.XML\apm-install-dir-119819-14424-sssgko.np08h'
    at Object.fs.mkdirSync (fs.js:872:3)
    at Object.mkdirSync (C:\Users\kulje\AppData\Local\atom\app-1.40.1\resources\app\apm\node_modules\temp\lib\temp.js:238:6)
    at Install.installModule (C:\Users\kulje\AppData\Local\atom\app-1.40.1\resources\app\apm\lib\install.js:96:35)
    at commands.push (C:\Users\kulje\AppData\Local\atom\app-1.40.1\resources\app\apm\lib\install.js:314:27)
    at fn (C:\Users\kulje\AppData\Local\atom\app-1.40.1\resources\app\apm\node_modules\async\lib\async.js:582:34)
    at Immediate.<anonymous> (C:\Users\kulje\AppData\Local\atom\app-1.40.1\resources\app\apm\node_modules\async\lib\async.js:498:34)
    at runCallback (timers.js:696:18)
    at tryOnImmediate (timers.js:667:5)
    at processImmediate (timers.js:649:5)