Getting a blank newline


#1

Hi All,

Whenever a saving from Atom editor I’am getting a blank newline in the file, I need to avoid this.Can anyone has a solution fo this.

Thanks!


#2

Hi,

Do you mean that each time you save there is a newline inserted at the end of the file? There is an option for this in the whitespace package settings called Ensure Single Trailing Newline


#3

Hi ,

Thanks for responding.
Yes I meant a newline is being inserted to the end whenever I’am saving a file, I need to avoid this, I tried **Packages > whitespace>Remove Trailing Whitespaces** But I didn’t get the option "Ensure Single Trailing Newline . Please suggest how can I get that option too.

Thanks!


#4

Hey,

From the Settings View, navigate to the Packages tab, locate the whitespace package and click the Settings button. Here you will find the settings for the whitespace package.


#5

Thank you so much it worked, Previously I was trying whitespaces, from the editor window directly that’s why I didn’t see this option to Ensure Sinlge Trailing Newline.