G-Sync windowed screen very slow


#1

I just wanted to share an issue I got with atom and G-Sync.

In the NVIDIA last driver update, they added G-Sync for the windowed screen mode. But with atom there is some serious lag like 5 fps cursor. If you set the G-Sync only for fullscreen mode it works fine. So didn’t know where to post this information because I found nothing on the web, so I share it here.


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?
  • What version of the nVidia driver do you have installed?
  • What nVidia card does your system have? How much RAM does it have?

#3
  • atom version : 1.0.11
  • OS : Windows 7 service pack 1

Can you reproduce
the issue after completely exiting Atom and restarting using atom
--safe ?

  • Yes I have just to activate G-Sync in windowed mode and open atom in --safe, and just wait 10 secondes moving with the mouse. The lag at the start is not constantly at 5 fps and more it goes more the lag is worse.
  • nVidia driver version : 355.82
  • Graphic card : GTX 970, 4096MB GDDR5
  • PC RAM : 6GB

#4

What exactly does this mean? Are you running Windows in a VM or something?


#5

No I’m running windows normaly, It’s an option in the drivers because unless recently, you could activate the G-Sync only for fullscreen application (windowed fullscreen isn’t the same). I got a picture of the driver panel.

I have a dual desktop (extended mode), one on a G-Sync monitor, the other without a G-Sync monitor, and the lag only appears when the atom window is on the G-Sync monitor. So i guess it will limitate a lot of debuger if you haven’t a G-Sync monitor : (


#6

The G-Sync monitor is your primary monitor?


#7

I tried the two configurations and the issue is still there on the G-Sync monitor. By the way the monitor model is an Asus ROG pg278q.


#8

Does Chrome manifest a similar behavior? What about playing canvas-based games? WebGl-based games? Do they exhibit this lag?
Sorry for the inquiry, just trying to understand if the issue is with a chromium incompatibility :smiley:


#9

Well chrome is working fine. I tried some WebGL demo like ( madebyevan.com/webgl-water/ ) and there where no noticable lag even when I tried to stress the program.


#10

Can you try running the profiler to see what’s causing the lag?


#11

Even though we’re not sure if it’s Atom or Electron at this point, it might be worthwhile opening an issue on the atom repo, to make some core devs aware.


#12

Can you try running the profiler to see what’s causing the lag?

I don’t understand the profiles or how to send you the profiles. I tried the 3 profiling possible and with the “Record Heap Allocations” atom work fine until I stop the profling. Maybe it helps.

it might be worthwhile opening an issue on the atom repo, to make some core devs aware.

Good idea I will post there. I think we have to wait some one else to have the same issue with a G-Sync monitor and Windows 7. Then we can assume that the problem come from the g-sync monitor. Plus maybe in the next drivers nVidia would correct the bug with atom unintentionaly.


#13

Yes, possibly.
But this may be an original compatibility issue, which could affect and annoy more users over time as they update their drivers like you did.

In that case, it’s good to already have your first report open on the issue.


#14

I also experience this behaviour when I have G-SYNC enabled for windowed mode and Atom is in the foreground, however I am running Windows 10 with a different G-SYNC monitor (Acer XB280HK).

It’s not just Atom. Slack, GitHub Desktop and Visual Studio Code also exhibit this behaviour (they are all Electron based as well I think).

For reference, G-SYNC is a proprietary adaptive refresh rate tech from NVIDIA; the idea is that the monitor only does a refresh when there is a new frame ready, with the goal of reducing latency and eliminating screen tearing.


#15

I have edited the issue I created on the atom GitHub. I have also created an issue on the electron repository. Thanks coldie for your feedback !

Link to the electron issue:

Link to the atom issue:


#16

I am still having this issue. Works fine when I disable g-sync, otherwise the lag is unbearable.


#17

I have this issue as well. I’m running a gigabyte 980 Ti xtreme gaming card with the dell 27 inch gsync panel. I first noticed it using the Discord chat app.

Since then I’ve noticed it also happens with the NZXT CAM 3.0 app as well (didn’t used to happen in 2.0 version). Also it happens in random other apps in certain dialog boxes and menus.

I’m thinking it has to be something with the way the window is drawn in Windows 10 or something along those lines. It’s like the application is unable to use hardware acceleration correctly.

I have noticed that when you turn off gsync and the terrible lag is gone, you can drag he window and it doesn’t move as smoothly as other Windows. I run a 144hz monitor so I usually notice smooth window dragging on the desktop. With gsync off the affected applications look like they are running at 30fps when you drag them. The mouse alone does not seem affected.

So I think it’s a deadly triad of 3rd party programming not playing well with Windows 10 and Windows 10 not playing well with gsync.

I don’t think this is going to be a big enough issue for ms to dive in and help but let’s cross our fingers and hope for an update that may address it.


#18

I also have this issue with G-Sync on. i7-5820k, 980 ti, 144hz ASUS monitor.

No issues on a C2D with integrated graphics and cheap standard monitor.