Ftp-remote: file will not open without restart

#1

I have to restart Atom about once an hour. The reason is a file will not open. After restarting Atom, all files open normally.

What I mean by “file will not open” is that double clicking the file in the file tree generates no response from Atom. If I restart Atom, or open a new atom window, the file will open. When this happens, all files are opening, except the one I am needing to open at that point.

How can I find the cause of this problem and fix it?

Any information provided will be extremely much appreciated.

#2

There is no package called ftp-remote. Do you mean ftp-remote-edit? Do you mean remote-ftp?

#3

yes, I am sorry for the misnomer. The package I am having the problem with is ftp-remote-edit.

#4

Did this start recently? Does it work for a little while and then stop working, or does it just not work at all until you reload Atom?

I can’t really help you troubleshoot a package I’ve never used, but I can suggest atom-commander as an alternative while you ask at the repository to see if the developers have any insight.

#5

Thank you for the response.

It’s been this way for more than a year, except much less frequent,

I just updated the package since starting this thread. Since then it has not happened. I will let you know how it goes from here.

#6

At this point, I think it is safe to say that updating Ftp Remote Edit to version 0.15.2 resolved the problem. I don’t know what version I had been on, only that it had been at least five months since upgrading. I could not spot in the app’s changelog where it was fixed, but fixed it seems to be.

With that fixed, I would say Atom and all the packages I run operate flawlessly. I don’t think that has been true for any IDE I have used since 1989 (MicroCobol running on MS DOS).