Fortran Package


#1

I am trying to use atom for Fortran code. But I am not getting the Fortran grammar working and the code looks like normal text. I created init.coffee file as suggested in the link https://atom.io/packages/language-fortran. But its not working. I restarted Atom after creating init.coffee. Can someone please help.


#2

Can you select the language with ctrl-shift-l?


#3

Yes. Thanks. I can use Fortran font now.


#4

It is possible to set the grammar from init.coffee, but the official way to customize language recognition is to use a config.cson setting. To create the same effect that the language-fortran readme suggests, you can use the following configuration:

'*':
  core:
    customFileTypes:
      'source.fortran.punchcard': [
        'f'
      ]