Form fields' content not visible - bug?


#1

I’m using atom v1.26.0 on MacOS. For a couple of months now I’ve lived with the fact that the contents of any form field (open file via cmd+alt+o, the palette via cmd+alt+p, search/replace via cmd+f, …) is invisible, even though there may be characters there, or I type them in the field, they remain invisible. See the screenshot of the Preferences pane.

Any help is appreciated.


#2

It’s probably CSS. What do you have in your styles.less for atom-text-editor or atom-text-editor[mini]? If nothing, you can use the developer tools (View -> Developer -> Toggle Developer Tools) to view that part of the UI and see what style rules are being applied.


#3

Another possibility could be this issue?

If it ends up not being a CSS issue, try the suggestion in https://github.com/atom/atom/issues/17094#issuecomment-379344427.


#4

Thanks @DamnedScholar and @rsese for your replies! For some reason, even though I’m “Watching” and will therefore receive notifications, I didn’t receive any. Sorry for the delay of my response!

@DamnedScholar: I looked at the LESS file but nothing changed when I tinkered with it.

@rsese: Yes, that seems to be the problem! I’ve managed to write an Apple Script to launch Atom with the --disable-gpu command line option, and everything works again (somewhat slower it seems, but was to be expected).

Thanks to both of you!

Just for documentation’s sake:

tell application "Terminal"
   set currentTab to do script ("atom --disable-gpu; exit")
end tell

#5

What’s in it? What did you do? What theme are you using?