Font problem in 126


#1

This isn’t a big deal but when I switched to 126 the font I normally use quit working. I use “input mono narrow” and on 126 the settings field was missing the spaces and said “inputmononarrow”. When I corrected it the font didn’t work and showed helvetica. I switched to “source code pro” which is working fine.

So one font broke. How weird.


Font problem in UI variables
#2

Seems like a lot of things was broken with 0.126, events registered using on are simply ignored in many places, soft wrap stopped working for me. I guess there was some changes regarding the settings as well.


#3

I can’t get any fonts (include Source Code Pro) to work. I can adjust the font size as normal—but it’s always set in Inconsolata no matter what I tell it.


#4

Is this issue related to this topic?


#5

No. The font name is definitely correct and not working. Also the font name which worked before got clobbered in the change to 126.


#6

Also a No here. My font was working in a prior version and I just didn’t notice it reverting to Inconsolata until later. Even typing “Courier” gives me…Inconsolata. :stuck_out_tongue:

I still have the problem in 127 too.


#7

This problem perhaps exists in 127 as well?

The last couple days I haven’t been able to switch my font from whatever terrible font is defaulted, as Atom is no longer attempting to use the font from any installed theme (I tried them all).

I’d love to switch to source code pro, but even adding that in to the settings is not switching the font anywhere. Seems to be only the text window though, not the File Tree or Tabs.


#8

The font setting only affects the main editor view. Fonts for the rest of Atom are controlled by the theme. If you want to change the other fonts, you can put something in your styles.less file:

html, body, .workspace {
	font-family: "My Preferred Font";
}

Why can't I change the font? (Problem Solved. The answer is inside.)
#9

What platforms are people on where they can’t set the font?

0.126 shipped Chrome 37 which I didn’t know had any known font issues.

The settings view shouldn’t have changed at all, there were no recent fixes there, so I’m surprised by this “font name is missing spaces issue”.

Is it also wrong in the ~/.atom/config.cson file or is it just presented incorrectly in the settings view?


#10

Looking into this. Font measurement changed pretty dramatically in Chromium 37, but we thought we fixed everything by disabling subpixel font scaling.

@abe The soft-wrap issue was an error of judgment on my part and is being reverted on the next release. Are there any other cases where legacy events aren’t being emitted properly?


#11

I’m having trouble reproducing this. What themes are people using? Also, just in case, can anyone reproduce this with atom --safe?


#12

I know that @mark_hahn is on Windows. Perhaps you can try on that platform first? I haven’t seen this on OS X.


#13

I can’t repeat the disappearing space problem. It might have only happened when I first switch to 126.

I just checked and both the settings field and the computed CSS properties on the text are correct. But I’m seeing something like helvetica. It is as if that font doesn’t exist, but it worked fine until the moment I switched to 126. Could it be a chrome bug?


#14

I found this issue on Chromium. I wonder if it’s related. It would be interesting to see if this problem still happens after disabling DirectWrite as suggested in https://github.com/atom/atom/issues/3540


#15

Shot in the dark @mark_hahn, but is it possible that this is a case sensitivity issue with the font name? Some of the things they’re describing in that Chromium issue make me wonder about that.


#16

I didn’t notice much issue except for the tokenized event since it was enabling the minimap to render.
I was just a bit confused at first by seeing that some event were deprecated when using on and some other were not.


#17

Hmm. On windows I have only seen the font filename, which by coincidence is the name without spaces. I don’t actually know what the case should be. If it has something to do with filenames then case doesn’t matter.


#18

For what it’s worth, I no longer have the problem. I can’t say when it corrected though. Could have been a simple app reboot even.