Folding shortcuts don't work


#1

Hi. I’m new to Atom and I like it very much. So, wanting replace Netbeans IDE with Atom I’m trying to setup some feature I need. One of them is code folding/unfolding that works like a charm using the menu commands (I like a lot I can choose the level to fold/unfold).
But the keyboard shortcuts just don’t work: ctrl-alt-[, ctrl-alt-], ctrl-alt-{, ctrl-alt-} just print brackets and curlybraces without folding the code.
Googling a lot I found there’s some problem with non-US keyboards and the mine is spanish. But it looks like the other had a problem completely different: thay wanted disable native keybindings in order to can type some character with their German or Polish keyboard. On the contrary, I want just to use native keybindings but currently they don’t work for folding and unfolding functions (ctrl-a, for instance, works fine and the same I can tell about increasing/decreasing font size).
To be clear, when I type ctrl-alt-[ I get a couple of brackets [] instead of have the current row folded or unfolded. Nothing at all happens if I use ctrl-alt-shift-[
Am I missing something crucial?
Thank you so much for your help.


#2

The easiest thing might be to change the keybindings so that they don’t use alt.


#3

Hi Damned Scholar. Thank your trying to help.
I’m wondering why you’re saying that.
I overrride some keybinding in my keymap.cson and I have seen the problem seems to be inherent not to Alt key but to brackets, curliybraces, apostro`phes and so on.

For instance, replacing ctrl-alt-{ (edior:fold-all) with ctrl-alt-shift-F works fine. The same I did for other keybindings, such as editor:fold-current-row, replacing ctrl-alt-[ with ctrl-alt-f.

So the problem seems to reside in punctuation signs instead of special keys. I have a spanish keyboards but I don’ have any problem at all using it within the editor: it is fully supported and I can type any char I need: the issues arise only with keybindings. Very strange, I think.


#4

Because the common interactions with foreign-language keyboards that I’ve read about have had to do with the Alt Gr key.

So the problem seems to reside in punctuation signs instead of special keys. I have a spanish keyboards but I don’ have any problem at all using it within the editor: it is fully supported and I can type any char I need: the issues arise only with keybindings. Very strange, I think.

I’m not sure why it’s happening, aside from the apparent translation funkiness.


#5

I see. Well I’ll go ahead overriding keybindings: the important thing is to make it work :slight_smile: