Flow Javascript


#1

So recently whenever I open a javascript file, it opens it using the syntax “Flow Javascript”. This has only started happening within the last couple weeks and I can’t find a way to change it. I looked through the packages and i couldn’t find the package it was related too. I didn’t even install anything new. I changed the file type extension in “config.cson” and it still won’t open with the Babel syntax (I disabled the standard JavaScript syntax). The weirdest thing is that “Flow Javascript” isn’t even in the list of available syntaxes. Does anyone have any suggestions or solutions?


#2

Same here…


#3

This sounds related to Tree-sitter getting enabled by default in 1.32 (http://blog.atom.io/2018/10/23/atom-1-32.html#tree-sitter).

Does this happen with any JavaScript file or files where you’re using Flow?

Also what version of Atom are you running?

A workaround would be to temporarily disable Tree-sitter at Settings > Core > Use Tree Sitter Parsers but it would be great to confirm what the issue is here and if/what changes the team might need to make.


#4

Use VS Code and all problems are gone…


#5

@rsese - I am not using Flow but it was occurring opening any JS file. Disabling Tree Sitter did the trick for now thanks!


#6

Huh that’s interesting, this happens with any JavaScript file you try? So if you downloaded and opened this file, Atom uses “Flow JavaScript”?

Does the behavior reproduce in safe mode (atom --safe)? Also what version of Atom are you running?


#7

@rsese Confirmed.

Now another issue when I disable the Tree Sitter is that https://atom.io/packages/linter-eslint isn’t running properly :man_shrugging:


#8

Yes both behaviors still happen in safe mode.


#9

Weird, I’m not sure why that file would identify as Flow for you - are you on the latest hotfix release @samueldelesque (currently 1.32.2)?

Also, do you have anything in your config file related to language recognition?


#10

@rsese yes I am on 1.32.2. Ah that’s so weird if I reset my config now everything works again… When it started failing I disabled some packages that seems to have been the issue. Now if I enable useTreeSitterParsers it detects it as JavaScript (rather than babel), but that’s fine. Here’s the config that works for me:

"*":
  core:
    disabledPackages: []
    telemetryConsent: "no"
    useTreeSitterParsers: false
  editor:
    fontSize: 15
    tabLength: 4
  welcome:
    showOnStartup: false

Thanks for your help!