[FIXED](Was using old binaries, v1.20.1 fixed it) / Messed up font in os modal windows (Fedora 25)


#1

Hi,

Its my first problem encountered on Atom, which still remain my editor of choice.

But recently I had to use it (Atom) on my laptop running Fedora 25.

But I have this weird bug where the font used in the modal windows to load things from the file system (like a project or whatever), the font goes crazy:


The problem is on the modal on the right. On the left you can see a “normal” window.

I have no idea where this comes from…


Square symbols when trying to open or save files
Missing font for dialog box?
#2

It’s no help to you at all, but I’ll just add I’ve seen the same problem with mancy which is also based on Electron. And yet my atom installs always work … weird. (Oh, Fedora 25 and 26, gnome desktop, wayland)


#3

What version of Atom are you using? Can you try upgrading to the latest version?


#4

Was using 1.9.x and just updated to 1.11.1, still the same problem.


#5

Hey,

1.11.1 is a very old release. The current stable version is 1.20.1. We recently had an issue for this on atom/atom and it was resolved by upgrading Atom. They were on 1.11.1 in that issue /cc: https://github.com/atom/atom/issues/15741


#6

Indeed !

My bad, just typed “Atom for Fedora” on Google, I guess I found old binaries, I didn’t check…

So I’m now with Atom 1.20.1, and the problem is fixed.

Thank you very much, this was a bit silly :stuck_out_tongue:
My bad again !


#7

You’re welcome :slight_smile:

The latest version is available at https://atom.io/releases if you want to keep the link around for future updates :slight_smile: