Find In project Malfunction?


#1

Hi,
I have been facing issues with the Find in Project feature. The content of the template files that are present inside the apm folder never turn up in a search at the root level directory “atom”. However on selecting the “apm” folder and doing a search in directory it gives me the required file in which the search word is present.
Another weird behaviour with the Find in project Feature is as follows. I am not sure how to frame this so I will illustrate the steps that lead to this behaviour.

  1. Open the apm folder inside the atom directory in atom.
    2)Ctr+Shift+F the keyword “Alive”. You do not get any results.
  2. Navigate to the folder apm/node-modules/atom-package-manager/templates within the tree view.
  3. Now right click on the “templates” folder and do a “Find in Project” for the Keyword “Alive”.
  4. Now you get the correct search results indicating the locations where the keyword is present.
  5. Now click back on the parent folder “apm” and perform a “Find in Project” for the keyword “Alive”. This time the search results appear.

Am i missing the functionality of how these features work or is it some issue with the search features. My apologies on not being able to frame it in a cleaner and less verbose manner.
Any insights will be appreciated. A lot of time got wasted due to the false results of these features.


#2

By default, Atom ignores files that are matched by your .gitignore files. If you look at the .gitignore in the Atom source code project, you’ll notice this line:

node_modules

Which you’ll also note matches the folder that you navigate to in step #3.

To test my theory that this is what was happening for you, I opened the file apm/README.md and noted that it contained the word folder. So I used Project Find to search for the word folder and the instance of the word in apm/README.md showed up as the first item in the results list.

You can turn off this feature of ignoring Git ignored files and folders by opening the Settings View and unchecking this setting:


#3

@leedohm Thanks a lot for that!